Підвищення системних вимог DataLife Engine

Дорогі друзі,

Поступово приходить час коли необхідно збільшувати вимоги до мінімально встановленого, щоб скрипт міг продовжувати свій розвиток.

В даному випадку мова піде про версії PHP встановленому на сервері. На даний момент мінімальною вимогою до PHP, є версія 4.3.x і вище, однак четверта лінійка гальмує розвиток скрипта, тому все таки необхідно тим, у кого на сервері встановлена ще четверта лінійка, переходити на PHP5.

Отже починаючи з нової версії скрипта, рекомендованої версією PHP, є версія 5.1.0 і вище. Це необхідно для підтримки нових функцій DataLife Engine, однією з таких буде наприклад можливість ZIP стиснення JS файлів скрипта, в результаті якої їх розмір буде менше в кілька разів, і відповідно набагато швидке їх завантаження, а також примусове кешування їх в браузері, щоб вони потім не завантажувалися повторно.

Наявність PHP5 не буде мінімальною вимогою для нової версії, і DataLife Engine зможе працювати на PHP4, але він автоматично відключить не підтримуються нові можливості. І з кожною версією таких відключають можливостей буде все більше і більше.

Тому прохання все-таки знайти час і оновити безнадійно застарілий PHP4 на PHP5, поки є ще час зробити це не поспішаючи і не поспішаючи.
86